Project

General

Profile

Backport #3874

[PATCH] configure.in: Always add -mieee for Renesas SH4

Added by iwamatsu (Nobuhiro Iwamatsu) almost 9 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:32548]

Description

=begin
SH4 is CPU for embedded which developed by Renesas Electronics.
SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.
=end


Files

Associated revisions

Revision 4fd89308
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@29340 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision 29340
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

Revision d736170e
Added by kosaki (Motohiro KOSAKI) almost 9 years ago

  • configure.in: Always add -mieee for Renesas SH4. Thanks, Nobuhiro Iwamatsu. [Feature #3874] [ruby-core:32548]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@29342 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

History

#1

Updated by kosaki (Motohiro KOSAKI) almost 9 years ago

=begin
Comitted.

note, myself haven't tested this patch (and I can't get sh4 test environment in future too).
I believe you :)
=end

#2

Updated by kosaki (Motohiro KOSAKI) almost 9 years ago

  • Status changed from Open to Closed
  • Assignee set to kosaki (Motohiro KOSAKI)

=begin
Ruby:r29340 (trunk)
=end

#3

Updated by kosaki (Motohiro KOSAKI) almost 9 years ago

  • Category set to build
  • Status changed from Closed to Assigned
  • Assignee changed from kosaki (Motohiro KOSAKI) to yugui (Yuki Sonoda)
  • Priority changed from Normal to 3
  • Target version set to 1.9.2

=begin
Please consider to backport this to 1.9.2, 1.9.1 and 1.8.7. because

  • Debian need this patch
  • the patch is very small. It has no regression risk.

=end

#4

Updated by kosaki (Motohiro KOSAKI) almost 8 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r29340.
Nobuhiro, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874] [ruby-core:32548]

#5

Updated by naruse (Yui NARUSE) almost 8 years ago

  • Target version deleted (1.9.2)

Also available in: Atom PDF