Project

General

Profile

Bug #11521

[BUG] Segmentation fault at 0x00000000000418 ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-darwin14]

Added by TyrantDavis (Tyrant Davis) almost 4 years ago. Updated 30 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:<unknown>]

Description

I am new to coding and rails. When I try running rails server I get the segmentation fault. This was not an issue yesterday. I am not sure what went wrong. I tried reinstalling Ruby 2.2.1 and updating to 2.2.3 to no avail. Below is the report.

(snip)

Abort trap: 6

Files

bug-11521.log (77.6 KB) bug-11521.log nobu (Nobuyoshi Nakada), 09/11/2015 08:10 AM

History

#1

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

Tyrant Davis wrote:

I am new to coding and rails. When I try running rails server I get the segmentation fault. This was not an issue yesterday. I am not sure what went wrong. I tried reinstalling Ruby 2.2.1 and updating to 2.2.3 to no avail. Below is the report.

Very strange.
The segmentation fault itself is due to a usual rvm bug, mixing an extension library for different ruby
but 2.2.3 should raise a fatal error instead of segmentation fault.
Is the log with 2.2.3 same?

#2

Updated by TyrantDavis (Tyrant Davis) almost 4 years ago

Thanks for the feedback.

I am still riding version 2.2.1. I have been unable to install the 2.2.3 update. Per the 2.2.3 install instructions on https://rvm.io/rvm/security ( # install mpapis public key ) I used the command line:
gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3

It returned the error:
-bash: gpg: command not found

That failed so I tried command line:
curl -sSL https://rvm.io/mpapis.asc | gpg --import -

per the instructions. The error below was returned:
-bash: gpg: command not found
(23) Failed writing body
.
I started my journey into programming just a few days ago. This is uncharted territory. How do I resolve the rvm bug for 2.2.1 or should updating to 2.2.3 take priority? Your help is very much appreciated.

#3

Updated by shevegen (Robert A. Heiler) almost 4 years ago

Could you give 2.2.3 a try, just to have it easier for nobu to see if the error is different (or perhaps gone)?

#4

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

Tyrant Davis wrote:

It returned the error:
-bash: gpg: command not found

You need to install gpg, probably by homebrew or MacPorts.
OSX does not provide gpg (or pgp) by default.

Or, you can install ruby from the source tarball:

curl -O https://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.3.tar.bz2 &&
tar xpf ruby-2.2.3.tar.bz2 && cd ruby-2.2.3 &&
./configure --prefix=/ --enable-shared --enable-load-relative --disable-install-doc &&
make all install DESTDIR="$HOME/.rvm/rubies/ruby-2.2.3"

and then rvm list will show ruby-2.2.3.

#5

Updated by jeremyevans0 (Jeremy Evans) 30 days ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF